TF223006 – Fehler bei Work Item Import nach TFS Upgrade

Nach einem Upgrade von TFS 2010 auf TFS 2012 konnte eine angepasste Work Item Definition nicht in den TFS importiert werden. Sowohl beim Versuch mit dem Process Editor, als auch mit der witAdmin Konsolenanwendung trat folgender Fehler auf: „TF223006: You cannot modify the definition of a work item tracking object with your version of command-line tools as they are not compatible with the Web Services for Team Foundation Server. Contact your system administrator to determine how to upgrade your installation of team explorer to a version compatible with Team Foundation Server.”

Nach einem Versionsupgrade sollte auch unbedingt beachtet werden, dass für den Import von Work Item Definitionen, eine passende Version des Team Explorers oder des Visual Studios zur Verfügung stehen. In diesem Fall Team Explorer 2012 oder Visual Studio 2012.

Achtung: wenn zum Import die witAdmin Konsolenanwendung verwendet wird, ist darauf zu achten, dass sie aus dem richtigen Visual Studio Pfad heraus gestartet wird (C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\…)